2009. 1. 6. 15:06

처음 ffp을 설치하고, php와 mysql 서비스를 올리면 gd라이브러리를 사용할수 없습니다.

다음 명령어로 확인가능
php -i | grep GD

PHP Warning:  PHP Startup: Unable to load dynamic library '/ffp/lib/php/extensions/no-debug-non-zts-20060613/gd.so' - File not found in Unknown on line 0

위 메시지를 보시면 알겠지만 gd라이브러리를 사용할수 없다고 나옵니다.

이런 메시지를 만나면 다음 2가지 패키지를 설치한 후에 웹서버를 재시작 해주시면 됩니다.
libjpeg-6b-1.tgz, libpng-1.2.29-1.tgz

다음과 같이 패키지를 설치해 주시면 됩니다.
mkdir /mnt/HD-a2/imsi
cd /mnt/HD_a2/imsi

wget http://www.inreto.de/dns323/fun-plug/0.5/packages/libpng-1.2.29-1.tgz
funpkg -i libpng-1.2.29-1.tgz

wget http://www.inreto.de/dns323/fun-plug/0.5/packages/libjpeg-6b-1.tgz
funpkg -i libjpeg-6b-1.tgz

/ffp/start/lighttpd.sh restart

자 이렇게 해서 또 한가지 문제를 풀어나가는군요.

원본서버에서 받지 못할경우를 대비해서 패키지를 첨부파일로 올려놓겠습니다.
Posted by 굿데이

댓글을 달아 주세요